Home Forum The Makers Workshop CNC talk MACH 3 Job preparation?

This topic contains 6 replies, has 1 voice, and was last updated by  Trevor Harrington 5 years, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #940

    Trevor Harrington
    Participant

    Eyup,
    Well at long last all axis are moving and the spindle is spinning.
    My problem now is when I start to cut a Gcode file the machine goes to the correct offset G54 but cuts straight through the workpiece, started pulling hair out AGAIN.
    Any assistance would be greatly appreciated.
    Thanks in anticipation.

    cheers

    Trevor

    #948

    Paul Kelly
    Participant

    Trev, can ya post the start of your G Code?
    PK

    #952

    Trevor Harrington
    Participant

    PK
    Sorry I took so long I emailed it to Dwayne in mistake.
    Anyway this is a new file but got the same result

    Cheers

    Trevor

    Attached files

    #953

    Paul Kelly
    Participant

    So, assuming you are zeroing against your part (in G54) then your problem is caused by tool length compensation being used but no (or incorrect) tool lengths in the tool table.
    Almost nobody uses the tool table on machines like yours.
    Try editing the file above, removing any G43 words and deleting lines 120 and 150.
    PK

    #956

    Trevor Harrington
    Participant

    PK,
    Thanks for your reply.
    I have modified the code as you suggested but no go ( see attached )
    This is the procedure I am using ( right or wrong )

    1. Home machine ( zeros on all axis in DRO Machine Coords )
    2. Move spindle to centre of workpiece ( zero all axis on DRO )
    3. Regen toolpath.
    4. Move spindle away and hit go to zero to test G54 OK.
    5. Enter spindle speed and hit Cycle start.

    Result.( I removed the workpiece just in case )
    1.Spindle does not start. ( Spindle used to start before G Code modification )
    2.Spindle goes to top ( Home limit )
    3.Spindle decends to machine bed and starts to go through program.

    I must be doing something wrong !!!
    What do you think?

    cheers

    Trevor

    Attached files

    #959

    Paul Kelly
    Participant

    Try. General Config -> Ignore tool changes
    Sounds like the machine might be heading to some absurd position to do a change.
    Make sure you zero z (not in machine cords) on the top of the job.
    PK

    #963

    Trevor Harrington
    Participant

    PK,
    No luck Im afraid.
    Checkout General Config screenshot.
    Ignore tool change selected.
    Z zero not in machine cords.
    No tools in tool library.
    Im thinking it must be a setting incorrect somewhere but I have checked and for the life of me canot find it.
    I will keep trying.

    cheers

    Trevor

    Attached files

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.